* WGs marked with an * asterisk has had at least one new draft made available during the last 5 days

Ticket #152 (closed design: duplicate)

Opened 6 years ago

Last modified 3 years ago

range unit missing from other-ranges-specifier in Range header

Reported by: julian.reschke@gmx.de Owned by:
Priority: normal Milestone: unassigned
Component: p5-range Severity: Active WG Document
Keywords: Cc:
Origin: http://www.w3.org/mid/49D0DB5D.9020102@gmx.de

Description

In http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p5-range-06.html#rfc.section.5.4.2, we have:

  Range   = "Range" ":" OWS Range-v
  Range-v = byte-ranges-specifier
          / other-ranges-specifier
  other-ranges-specifier = 1*CHAR

Shouldn't other-ranges-specifier be something like:

  other-ranges-specifier = other-range-unit "=" 1*CHAR

...so that a recipient can parse the unit name out of the header in a generic way?

Change History

comment:1 Changed 6 years ago by julian.reschke@gmx.de

  • Status changed from new to closed
  • Resolution set to duplicate

Removed as duplicate of #151.

comment:2 Changed 3 years ago by mnot@pobox.com

  • Priority set to normal
  • Severity changed from Candidate WG Document to Active WG Document
Note: See TracTickets for help on using tickets.