* WGs marked with an * asterisk has had at least one new draft made available during the last 5 days

Ticket #267 (closed design: fixed)

Opened 4 years ago

Last modified 3 years ago

clarify PUT semantics

Reported by: julian.reschke@gmx.de Owned by:
Priority: normal Milestone: 13
Component: p2-semantics Severity: Active WG Document
Keywords: Cc:
Origin:

Description (last modified by julian.reschke@gmx.de) (diff)

There's a permathread about PUT-for-partial-update.

We should clarify that PUT can be more than "store this payload verbatim", but that the final state should not depend on the previous state of the resource (except when by design; such when doing versioning...)

Change History

comment:1 Changed 4 years ago by julian.reschke@gmx.de

I believe this can be closed as fixed as per [1158].

comment:2 Changed 4 years ago by fielding@gbiv.com

  • Status changed from new to closed
  • Resolution set to incorporated
  • Milestone changed from unassigned to 13

Yes, fixed in [1158]. The relevant paragraph added is

An origin server SHOULD reject any PUT request that contains a Content-Range header field, since it might be misinterpreted as partial content (or might be partial content that is being mistakenly PUT as a full representation). Partial content updates are possible by targeting a separately identified resource with state that overlaps a portion of the larger resource, or by using a different method that has been specifically defined for partial updates (for example, the PATCH method defined in [RFC5789]).

comment:3 Changed 4 years ago by mnot@pobox.com

  • Status changed from closed to reopened
  • Resolution incorporated deleted

comment:4 Changed 4 years ago by mnot@pobox.com

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:5 Changed 3 years ago by julian.reschke@gmx.de

  • Description modified (diff)
Note: See TracTickets for help on using tickets.