* WGs marked with an * asterisk has had at least one new draft made available during the last 5 days

Ticket #39 (closed editorial: fixed)

Opened 7 years ago

Last modified 4 years ago

ETag uniqueness

Reported by: mnot@pobox.com Owned by: julian.reschke@gmx.de
Priority: normal Milestone: 10
Component: p4-conditional Severity: Active WG Document
Keywords: Cc:
Origin: http://www.w3.org/mid/1161261658.29399.24.camel@henriknordstrom.net

Description

From experience I think it's also worthwhile to further stress the importance of ETag uniqueness among variants of a URI. Very few implementations get this part correct. In fact most major web servers have issues here...

Some even strongly believe that entities with different Content-Encoding is the same entity, arguing that since most encoding (at least the standardized ones) can be converted to the same identity encoding so they are in fact the same entity and should have the same strong ETag.

Attachments

i39.diff (6.3 KB) - added by julian.reschke@gmx.de 5 years ago.
Proposed example

Change History

comment:1 Changed 7 years ago by mnot@pobox.com

  • Component set to conditional
  • Milestone set to unassigned

comment:2 Changed 7 years ago by mnot@pobox.com

  • version set to 00-draft

comment:3 Changed 7 years ago by mnot@pobox.com

  • Type changed from design to editorial

comment:4 Changed 6 years ago by julian.reschke@gmx.de

Proposal:

Strong entity tags MUST be unique for each representation of a particular resource; they must change if the representation varies over time and/or because of the use of server-driven content negotiation.

comment:5 Changed 6 years ago by julian.reschke@gmx.de

  • Owner set to julian.reschke@gmx.de

comment:6 Changed 6 years ago by julian.reschke@gmx.de

  • Milestone changed from unassigned to 04

comment:7 Changed 6 years ago by mnot@pobox.com

  • Type changed from editorial to design

proposal is for inclusion in p4 section 7.1. However, need WG buy-in for adding a new requirement; flipping to design.

comment:8 Changed 6 years ago by julian.reschke@gmx.de

  • Milestone changed from 04 to unassigned

comment:9 Changed 6 years ago by mnot@pobox.com

  • Milestone changed from unassigned to 06

comment:10 Changed 6 years ago by julian.reschke@gmx.de

  • Milestone changed from 06 to unassigned

comment:11 Changed 5 years ago by henrik@henriknordstrom.net

The problem is basically isolated to Content-Encoding. For the other aspects most seem to get it right.

Suggested resolution is to add an informal example showing Content-Encoding negotiation responses, and with a note on why the ETag is different.

This issue is also somewhat related to the terminology discussion.

comment:12 Changed 5 years ago by mnot@pobox.com

  • Priority set to normal
  • Type changed from design to editorial
  • Severity set to Active WG Document

comment:13 Changed 5 years ago by julian.reschke@gmx.de

1st step:

add example showing how etag differs for Content-Encoding: gzip and no Content-Encoding. Explain that things would be different for Transfer-Encoding.

Changed 5 years ago by julian.reschke@gmx.de

Proposed example

comment:14 Changed 5 years ago by julian.reschke@gmx.de

From [800]:

Add an example for an ETag varying based on the Accept-Encoding (related to #39)

comment:15 Changed 4 years ago by julian.reschke@gmx.de

  • Status changed from new to closed
  • Resolution set to incorporated
  • Milestone changed from unassigned to 10

comment:16 Changed 4 years ago by mnot@pobox.com

  • Status changed from closed to reopened
  • Resolution incorporated deleted

comment:17 Changed 4 years ago by mnot@pobox.com

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.