* WGs marked with an * asterisk has had at least one new draft made available during the last 5 days

Ticket #61 (closed editorial: fixed)

Opened 7 years ago

Last modified 7 years ago

Redirection vs. Location

Reported by: mnot@pobox.com Owned by:
Priority: Milestone: unassigned
Component: p2-semantics Severity:
Keywords: Cc:
Origin: http://www.w3.org/mid/462779E2.6010701@gmx.de

Description

The definition of the Location header currently says: "The Location response-header field is used to redirect the recipient to a location other than the Request-URI for completion of the request or identification of a new resource. (...)" The issue is that this can be read as if the "...or identification..." can be read as applying to the "redirect" part.

Change History

comment:1 Changed 7 years ago by mnot@pobox.com

One simple fix seems to be to swap the two parts of the sentence, as in...: "The Location response-header field is used for the identification of a new resource or to redirect the recipient to a location other than the Request-URI for completion of the request. (...)"

comment:2 Changed 7 years ago by mnot@pobox.com

  • Component set to messaging
  • Milestone set to unassigned

comment:3 Changed 7 years ago by mnot@pobox.com

  • Component changed from messaging to semantics

comment:4 Changed 7 years ago by mnot@pobox.com

  • Type changed from design to editorial

comment:5 Changed 7 years ago by julian.reschke@gmx.de

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in [237]:

Resolve #61: change the order of statements to make it clearer that "identification of a new resource" is not a case of redirection (closes #61).

Note: See TracTickets for help on using tickets.